muzamilali3299

Getting Noindex tag When Enabling Cloudflare

by @muzamilali3299 (121), 2 weeks ago

Can anyone help me in this?

When I am enabling Cloudflare to prevent the spam bots traffic because we are also running PPC & the budget gets wasted (CPC) if we don't implement Cloudflare due to bad traffic. Now the issue is When I enable Cloudflare & I test my website, 403 error appears & no-index, nofollow tag is implemented by default & Google is unable to crawl our website. I don't know why this is happening? Is this issue occuring from Cloudflare's side OR our web hosting? Can anyone please help me with that.

Thanks!

100 Views
0 Upvotes
3 Replies
3 Users
Sort replies:
binayjha
by @binayjha (1568), 2 weeks ago

This link might help you,

https://developers.cloudflare.com/pages/platform/headers

Or, contact your developer to fix the issue. It's easy, just need to send a header information.

yoJamesMarchanturusername

I think there can be a technical error with the robot txt. You can edit it easily if you have a WordPress website. Install the plugin called File Manager. In file manager go to public HTML and edit robot.txt and allow bot and give (*) special character to tell google to index it quickly. Try it and please tell me if it is helpful or not.

muzamilali3299
by @muzamilali3299 (121), 1 week ago

Hello,

Thanks for your valuable suggestion brother,

My Website is Crawled, But the thing is when I enable Cloudflare to prevent spam traffic, It seems like Cloudflare by default implement noindex, nofollow tag from the backend. If i disable Cloudflare everything is perfect!

Join the forum to unlock true power of SEO community

You're welcome to become part of SEO Forum community. Register for free, learn and contribute.

Log In Sign up